Форум: Форум PHPФорум ApacheФорум Регулярные ВыраженияФорум MySQLHTML+CSS+JavaScriptФорум FlashРазное
Новые темы: 0000000
Самоучитель PHP 5 / 6 (3 издание). Авторы: Кузнецов М.В., Симдянов И.В. Самоучитель MySQL 5. Авторы: Кузнецов М.В., Симдянов И.В. PHP Puzzles. Авторы: Кузнецов М.В., Симдянов И.В. MySQL 5. В подлиннике. Авторы: Кузнецов М.В., Симдянов И.В. PHP 5/6. В подлиннике. Авторы: Кузнецов М.В., Симдянов И.В.
ВСЕ НАШИ КНИГИ
Консультационный центр SoftTime

Форум Apache

Выбрать другой форум

 

Здравствуйте, Посетитель!

вид форума:
Линейный форум Структурный форум

тема: Откуда скачать Apache?
 
 автор: Mookapek   (17.02.2015 в 01:40)   письмо автору
 
 

Хочу обновить версию своего Apache, только не пойму, откуда именно его скачать. На сайте apache куча каких-то ссылок, ничего не понятно. С какого-то зеркала скачал скачал вот такое httpd-2.4.12-win32-VC11.zip, но там нет установщика, просто папка с файлами Апача. Что, просто архив распаковать и все, без всякой установки? Еще там в readme сказано, мол, установите сначала Visual C++, каким боком тут Visual C++ тоже не понятно. Апач нужен под Windows. В общем проблема....

  Ответить  
 
 автор: Sfinks   (17.02.2015 в 02:43)   письмо автору
 
   для: Mookapek   (17.02.2015 в 01:40)
 

http://apache-mirror.rbc.ru/pub/apache/httpd/binaries/win32/
Цитата:
> The Apache HTTP Server Project itself does not provide binary releases of software, only source code. Individual committers may provide binary packages as a convenience, but it is not a release deliverable.

Установите готовую сборку XAMPP, Denver или OpenServer и не парьтесь. Судя по вопросу "каким боком тут Visual C++", скомпилировать из исходников вы его не сможете.

  Ответить  
 
 автор: Mookapek   (17.02.2015 в 02:49)   письмо автору
 
   для: Sfinks   (17.02.2015 в 02:43)
 

Перед тем как установить XAMPP, надо ли удалить текущие Apache, PHP и MySQL?

  Ответить  
 
 автор: Sfinks   (17.02.2015 в 09:06)   письмо автору
 
   для: Mookapek   (17.02.2015 в 02:49)
 

я бы удалил

  Ответить  
 
 автор: Ъ   (05.03.2015 в 02:01)   письмо автору
 
   для: Mookapek   (17.02.2015 в 01:40)
 

Если Вам нужен не Apache OpenOffice, а сервер для разработки сайтов (раз уж вопрос на этом форуме и в этом разделе — то скорее всего я прав), то Вам нужен Apache HTTP Server. Сайт этого добра: httpd.apache.org. Далее видите текст на ненашинском: «Want to try out the Apache HTTP Server?», и там же: «download page» в виде ссылки. Шлёпаем по ней. На странице далее видим стабильную версию («Stable Release») и устаревшую («Legacy Release»). Качаем стабильную. На сегодняшний час это: «2.4.12 (released 2015-01-29)». Вид архива tar.bz2 или tar.gz выбираем на свой вкус.

  Ответить  
 
 автор: Sfinks   (05.03.2015 в 22:32)   письмо автору
 
   для: Ъ   (05.03.2015 в 02:01)
 

> Вид архива tar.bz2 или tar.gz выбираем на свой вкус.

И кто из них для винды?

  Ответить  
 
 автор: Ъ   (06.03.2015 в 04:33)   письмо автору
 
   для: Sfinks   (05.03.2015 в 22:32)
 

Ох, да, мой косяк, намёк понят )))

Это исходные файлы как добыть я описал. Для распаковки на Windows нужно скачать здесь:
www.apachehaus.com/cgi-bin/download.plx

Опять же (на сегодняшний день):
Apache 2.4.12 (например, httpd-2.4.12-x86.zip) — для 32-битных систем;
Apache 2.4.12 x64 (например, httpd-2.4.12-x64.zip) — для 64-битных систем;

  Ответить  
Rambler's Top100
вверх

Rambler's Top100 Яндекс.Метрика Яндекс цитирования